Sort by:
View:
  • Home
  • Articles Posted by Keith Solomon
  • (  »   Page 3)

Written by Keith Solomon

CMS-Like Admin Menu – Version 2.0 Released.


In case you haven’t noticed the update notification on your WordPress plugins screen, I released an updated version this morning. No functional changes have been made (or needed), but the plugin in now 100% compatible with WordPress 2.7. You can get the updated version either via the automatic update function, or you can head over to the plugin page to grab a copy manually.

You may also notice that there are now two download options on the plugin page. This is because version 2.0 is only for WordPress versions 2.7 and above. The menu item numbers changed in 2.7, so the new version of the plugin won’t work correctly on WordPress 2.6 or earlier. If you’re still running version 1.0 of the plugin on an older version of WordPress, there’s no need to update, as you already have the newest version that will work for you (though, I highly recommend you upgrade WordPress as soon as possible to take advantage of the new features and security enhancements).

As always, please feel free to leave any comments on the plugin page.

Internet Explorer 6…Time to call it a day?


As web developers, we all know IE 6 is a major PITA. It’s CSS support is horribly broken (google “CSS IE hacks” and enjoy browsing through 4.7 million hits), with the CSS box model being the biggest culprit. It was released in 2001, when most of the technologies we use today were in their infancy, if they were being used at all. These days, it’s really starting to show it’s age.

Which is why, effective today, I’m not supporting it any longer.

It may seem strange coming from someone who develops web sites for a living to drop support for one of the most widely-used browsers on the market, but let’s face facts. According to Net Applications, IE 6 has been losing market share for at least the last year. and it now barely ranks number 2 behind IE 7; with only a scant 3.28% lead on my recommended browser, Firefox 3. This tells me that the majority of Windows users have either upgraded to Vista (which comes with IE 7), or have finally upgraded their XP install to IE 7. Either way, it seems that IE 6’s race has been run, and it’s time to move on.

Question for the WP theme devs in the audience


I mentioned this on twitter, but I wanted to get it out here too…if you use TextMate to do your theme development, would you use a bundle that contains a variety of functions for your functions.php file? I’ve got quite the collection set up that I use regularly, and I am thinking of releasing it for download. Any comments are appreciated, leave them either here, or send me a @reply on twitter.

News, Updates, etc.


Ok, first things first. I’ve upgraded to WordPress 2.7…have you?

For the most part, my plugins still work work without need for an upgrade, with the exception of my CMS plugin. It needs some adjustment to account for the new menu system in 2.7. It’ll still work as intended, it just doesn’t fit in with the rest of the new menu design. Right now I’m not sure when I’ll get a fix pushed out for it, but if you use the plugin, you should get an upgrade notification when I release the upgrade.

And while we’re on the subject of plugins, I’ve almost come to the conclusion that version 4.5 of CTC is the last one that will be released. It does more than I ever intended it to do as it stands, and it works without issue. I’m still going to try to get the tag exclusion feature to work, and that will probably incur a version bump, but as of now I have no timeline on when this might take place.

EDIT (12.16.08): The download links for my plugins are now working again. The download manager I use wasn’t quite ready for WP 2.7, but it has been upgraded, and is now functioning correctly.

Quick PopcornHour Firmware Tip


When upgrading the firmware on your PopcornHour A-100 Network Media Tank, you might end up with a hung machine before any operations take place. You’ll know this has happened because your TV screen will go black as soon as you start the process. If this happens to you, there’s a simple solution…remove your custom theme. You don’t have to delete it, just renaming the theme folder form _theme_ to theme and rebooting the A-100 is enough to get you in the firmware updating business. Once you’ve updated, you can safely re-apply your theme and be back in business.

Ghost Rider — Simpsons-ized


Ghost Rider has long been one of my favorite comic books, so imagine my surprise and joy to see this in my feed reader this morning…

The artist is doing a month of Marvel characters done in the style of The Simpsons. I’m glad he’s doing some of the more obscure Marvel characters. Take a look at his gallery…he’s VERY good.

WordPress Plugins Upgrade Tip


Got a WordPress-powered blog that’s been around a while (since 2.1 or thereabouts)? Is your Admin panel telling you that you have plugins that need to be updated, but when you try, you end up downloading the WordPress Widgets plugin? Fear not, there is a (possibly) easy solution. Check your plugins folder for a “widgets” folder.

I was updating the plugins on my development server this morning when I ran into this issue. The fix was simple; I just moved everything in the widgets folder up to the plugins folder, and like magic, the upgrade notifications went away. So if you’re having this issue, give this tip a shot.

Menu